There was a problem to connect USB device to hosted Windows7.

I always get “Failed to attach USB device to the virtual machine. USB device with UUID is in use by someone else” error. Screenshot:

Screenshot 2014-12-10 02.17.31

To remove it I did the next:

– With the VM powered off, go to Settings–>USB and check “Enable USB 2.0 (EHCI) Controller”
– Turn on the VM and plug in the device
– Go back to Settings–>USB and create a USB device filter:
— Click the green plus
— Select your device from list
— Edit the filter properties. Just get context menu on device and select “Edit filter”
Name, Vendor ID, and Product ID are the only fields populated. All other fields should be blank, and Remote should be set to “Any.”
– Restart the VM and plugging in the device once the VM is running.

Hope it helps.


4 Comments

Joseph · 31 May, 2016 at 17:17

Thanks for your sharing. This work for me.

renan · 9 August, 2016 at 14:58

hey igor, that was terrifc, there are many websites trying to explain but you made it happend. simple like every inteligent solution. tks man.

Matt · 19 November, 2016 at 05:32

I followed these steps was still received the same error. In addition I had to unload any kernel extensions related to the USB device from the Mac host. From within terminal:

“kextstat” to list all loaded kernel extensions

“sudo kextunload -b {kextname}”

After that the in use by someone else error was gone and everything worked.

latifa · 27 November, 2016 at 00:35

Thank you so much

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.