How to fix “Invalid command ‘Header’, perhaps misspelled or defined by a module not included in the server configuration” for apache2 in Ubuntu

If you got:

message in error log of your apache2 web server under Ubuntu you need to do next: Run this command in terminal with sudo

Restart Apache2: Also run with sudo

Linux Ubuntu 10.04 driver for my Canon IP3600 IJ printer

Let me tell you how i installed Canon Pixma IP3600 printer driver in Ubuntu 10.04 Lucid Lynx and made it works.

Yesterday, i needed to install driver for my IJ printer. I tried to found it in Ubuntu software center, but it was unsuccess.

Next i downloaded the driver from official web site: Debian Linux Printer Driver .In this .tar archive i was found three files:

  • cnijfilter-common_3.00-1_i386.deb – common .deb file. Needs to  … i think … to all Canon printers.
  • cnijfilter-ip3600series_3.00-1_i386.deb – driver for printer with PPD file.
  • cnijfilter-common-3.00-1.tar.gz – source

I tried to install this .deb packages, but it was unsuccess. I’ve got an error depended with libcupsys2 library (in new release this library replaced by libcups2). I changed library libcupsys2 to  libcups2 in packages then rebuild it and install in my OS (Ubuntu 10.04) succesful. I show you how i did this. (more…)